Back to overview
Maintenance
Server Hibernation
May 4, 2026 at 11:00am UTC
–
May 27, 2026 at 9:15pm UTC
Affected services
Services
Resolved
May 27, 2026 at 9:15pm UTC
Maintenance ended
Affected services
Created
May 4, 2026 at 11:00am UTC
Server is put on scheduled hibernation due to sports center closing during exam periods
Affected services